DropsuiteNA - Dropsuite.com login issues – Incident details

Dropsuite.com login issues

Resolved
Major outage
Started 3 months agoLasted 3 days

Affected

Website

Major outage from 2:42 AM to 7:42 PM

Updates
  • Resolved
    Resolved

    Our investigating team has discovered that the issue was caused by a misconfiguration of our sign-in page. This has been resolved and everything should be working as expected now. If you are still experiencing any issues, please let us know at support@dropsuite.com

  • Investigating
    Investigating

    We have been informed that some customers are having issues logging into their customer portals through dropsuite.com. We have also noted that some customers are able to sign-in successfully but are directed to a partner portal page that is not current. Our teams are investigating this issue with all possible urgency. Please note that all backups are functioning normally. We will provide updates here as we have them. If you have any questions, please do not hesitate to contact support@dropsuite.com